sweet
script for After Effects

Manual

sweet
a tasty touch for your animation
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Introduction

What is Sweet?
Sweet is a preset based script for After Effects. It is a small but powerful platform that boosts your performance with either basic or complex animations.
Easy to use and set up - you will be running it in no time. Sweet gives you a vast
array of tools to improve on your workflow and adds that needed pinch of
tasty details just were you need them. The script is package based and its
library is updated on regular basis with new animations at aesweets.com.
Sweet is using the built-in features of AE and vector graphics – shape layers
that can be resized without loosing quality. Its capabilities are endless, ranging
from simple patterns and transitions to even typography and whole scenes
with cameras and lights.
We have included a unique and completely free tool – Colorize – that generates harmonic color combinations for your animations in just one click. You can
use it for inspiration throughout your work.
In the end we have built this tool because we needed to. We were missing
these features and we made them happen. It took more than 9 months working around the clock, but we love what we do and it is all love and passion we
have put in this project. Sharing it all we hope you will enjoy it even more.
Tihomir Trifnov a.k.a. Mastermind (programming)
Jelio Dimitrov a.k.a. Arsek (design)
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Installation

To install Sweet you simply need to follow these 2 easy steps:
1. After unpacking the archive you have received, copy and paste the files to
this specific folder of After Effects : “ScriptUI Panels”
• On Windows this folder is located in:
“(after_effects_install_path)/ Support Files/Scripts/”
• On Macintosh this folder is located in:
“(after_effects_install_path)/ Scripts/”
2. Allow Sweet to access the network so your copy can be registered. This
option is found under “General” tab of After Effects “Preferences”.
• On Windows this is located in:
“Edit > Preferences > General...”
• On Macintosh this is located in:
“After Effects > Preferences > General...”
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Installation on Windows

How to install Sweet on Windows
1. Extract the downloaded archive to a temporary folder.

2. Copy the extracted files and folder.
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Installation on Windows

3. Navigate to “after_effects_installation_folder/Support Files/Scripts/”

4. If the folder “ScriptUI Panels” does not exist, create new folder and name it
“ScriptUI Panels”. Then paste the copied files in it.
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Installation on Windows

5. Make sure all users that will run Sweet have access to read from and write to
“(Sweet)” folder to avoid unnecessary problems. Don’t update Sweet or install
new packs with users that don’t have these permissions. You can check this from
“(Sweet)1 > Properties > Security tab2 > Edit3“.

6. You are now ready to use Sweet!
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Installation on Mac

How to install Sweet on Mac
1. Extract the downloaded archive to temporary folder.

2. If folder with the archive name appears go inside that folder. Then copy the
files and the folder.
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Installation on Mac

3. Navigate to “after_effects_installation_folder/Scripts/”.

4. If folder “ScriptUI Panels” does not exist, create new folder and name it “ScriptUI
Panels”. Then paste copied items in it.
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Installation on Mac

5. Make sure all users that will run Sweet have access to read from and write to
“(Sweet)” folder to avoid unnecessary problems. Don’t update Sweet or install
new packs with users that don’t have this perm issions.
You can check this from “(Sweet) > Get info > Sharing & Permissions“.

6. You are now ready to use Sweet!
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Sweet User Interface

Sweet can be used as dockable palette or separate window. Its size can vary
depending on the space you have. To reduce or expand its size you can check the
Settings panel’s “Number of thumbnails” and “Hide logo” options.

This is how Sweet looks like:
1. Colors section - predefines the animation’s
colors. It can be set to Grayscale, Harmonic
or Single color which is set using the OS’s
default colorpicker. It also can be used as a
stand alone tool for color brainstorming
when the logo is hidden from the settings.
2. Category and subcategory menu - filters
the visible animations in the list (3).
3. Animations selection - select desired animations by single click on the thumbnail or
the “+” button. Unselect by clicking the selected thumbnails or by using the “Clear selection” button. Animations are created in the
order of selection.
4. Make it sweet - the big blue button that
makes it happen.
5. Info bar - shows the current status of
sweet or last action finished.
6. Sub navigation - brings up the Settings,
Activations info and About panels. The help
link opens this document or it’s web version if
the file is missing.
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Sweet User Interface

Settings Panel
1. Thumbnails - sets the number of
thumbnails in Sweet’s panel. This
can make Sweet go from compact to
useful for bigger screens.
2. Default color type - preselects the
color type next time you start Sweet.
3. Autoclear - clear selected thumbnails after all animations are generated.
4. Hide logo - for ultra portability or
if you plan to use Colorize as standalone tool you can hide the logo.
5. Animations position
*Current time - places new animations at the current time.
*Successively - places new animations one after another.
6. Animations offset - offsets animations from the positions where
they should appear.
Sweet’s colorize tool as standalone tool
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Sweet activation

Sweet by itself is free, but it requires activation and Animation Packs to be
used at its full potential. These packages require license to be used. After you
have successfully installed Sweet, you have a 7-day or 30 runs trial period of
the Starter Pack that starts to expire from the first moment Sweet loads. When
your free trial period expires Starter Pack will disappear and will require an
activation. An activation key, which unlocks single package for further use, can
be purchased at any time from aesweets.com.

How to activate Sweet
1. Run After Effects. If the script window or the dockable panel is not visible run
Sweet from “Window > Sweet.jsx” and you should see this screen after agreeing
to our End User License Agreement.

13

06

Sweet activation

2. Even though Sweet is free it requires an e-mail and key in order to be activated. Providing your e-mail you will generate a new free key for you. Sweet
will automatically finish the activation process through our web server. Make
sure it can be accessed temporarily by allowing access to aesweets.com in your
firewall and/or proxy server if you have one running. If the operation is successful you should see something similar.
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Animation Packs installation

In order to start using the fresh animation packages from aesweets.com, you
have to download, install and activate them. For “How to” on packs activation,
please refer to our “Animation Packs activation” section.

How to install Animation Packs
NOTE: If the automatic packages installation fails you can manually install
packs. Just copy the “(Packs)” and “(Thumbs)” folders from the extracted pack
archive to the “(Sweet)” folder without replaceing the old content:

1. To automatically install multiple animation packages after downloading the
archives from aesweets.com, extract their contents to a folder (“Packs extracted here” for example). You can extract as many packs as you want and install
them at once.
This is how your folder should look like:
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Animation Packs installation

2. From Sweet’s Activation info Panel press the “Browse for pack(s) folder..”
button under the “Add new pack(s)” section. Browse dialog will appear. Navigate to the package folder or the parent folder (ex. “Packs extracted here”).

3. If the installation is successful, Activation info panel will reload and you’ll see
your new packs in it. Now you have to activate them - see the next chapter.
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Animation Packs activation

After successfully downloading and installing your new packs (see section Animation Packs installation) you must activate them. This is done in the Activation
info panel. You can open it from the bottom of Sweet’s User Interface - Activations link.

How to activate Animation Packs
all at once
Sweet now provides a way to activate all your packs at once. Just copy your
e-mail and comma separated keys provided in your purchase e-mail or type
them manually then press the “Activate” button. Remember that one license
serves one computer*

* NOTE: If you plan to move your license to another computer you must uninstall all your licenses from the “Activation Info panel > Uninstall button” and
then make a request at support@aesweets.com for transfer of your key.

How to activate Animation Packs
one by one
17
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Animation Packs activation

1) With the Activation info panel opened - locate the pack that you want to
activate and enter your email and key in the “enter your email” and “enter your
key” fields with the info you received upon successful purchase.

2) Press the Activate button right next to the enter email and key fields.
3) If the activation is successful you should see “Active” written in green where
the Activate button used to be.
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How to use Sweet

We’ll cover the basics in this section. Here you will see how, with few clicks you’ll
be on your way creating countless animations and projects. For more detailed
“how to”s check our tutorials.

How to use Sweet?
1) Preselect the color of your animation. You can have Grayscale, Harmonic or
Single color selected. All animation parts are colored in the order of their appearance on the screen - this includes Strokes and Fill properties of the layers.
2) You can filter the animations by choosing category or subcategory.
3) Select as many animations as you want. You can select animations from
different categories and subcategories. They will appear in the order of selection.
4) Press the sweet and tasty button “Make it sweet”. Animations will start to
pop out layer by layer, composition by composition. Every new animation will be
placed above the layer that was selected just before hitting “Make it sweet”
5) Depending on your settings (in the Settings panel) animations will be place
at your current time - one over another, or one after another. You can change
the offset too (again from the Settings panel).
After all animations are created you can edit them at any time to achieve more
personalized results. Every property is using simple keyframes so no need to be
expressions gurus here :D~~
See the images on the next page for a preview.
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How to use Sweet
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Changelog

From beneath the ground, up to the latest version:
v1.14 25.05.16 | Activation process optimization and bug fixes.
v1.13 08.10.14 | Hot fix for AE CC 2014 (v13.1)
v1.12 29.04.14 | New type of packages support
- More complex algorithm for building animations
- Support for Lights, Cameras, Solids, Text layers, Nulls and Adjustment layers
- Version check for future packages
- Improvement: Loading time improved more than 68% with 12 packs (about 3 sec)
- Fixed: No image thumbnail fixed

v1.11 18.02.13 | Major release

- AE CS5 to AE CC support added (CC must be upgraded to at least 12.2)
- All packs rebuild for all AE versions
- Improvement: Multiple packs installation added
- Improvement: Multiple packs activation added
- Improvement: Pack activation is twice as fast
- Improvement: When new package is activated license file is optimized dramatically
- Fixed: Sweet crashes when browsing for packs (CC related)
- Fixed: Sweet crashes when activating packs (CC related)
- Fixed: Category menu UI bugs
- Fixed: Sweet trial not starting if AE is not restarted
- Fixed: Colorize tool not working in trial mode
- Lots of small bug fixes

v1.10b 25.12.13 | CC Beta release
- AE CC support
- New category menu
- Lots of bug fixes

v1.03 16.10.13 | Bug fixes

- Fixed: Sweet crashes when dialog is opened, autoupdate for the info bar is
removed

v1.02 09.10.13 | Bug fixes, Improvements

- Feature: Sweet is now more tidy and has info bar
- Improvement: Creating animations now starts faster
- Fixed: Third party scripts crash sweet when loading packs
- Fixed: Minor UI bugs
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Changelog

v1.01 02.10.13 | Bug fixes

- Fixed: “Make it sweet” not working after Starter Pack trial expires

v1.00 21.09.13 | Full version, public release ( it would’ve been easier to make a
baby for 9 months :] ).
- Few bug fixes
- Pack installation feature - checked

v0.67 11.08.13 | First public beta.
v0.66 02.08.13 | Inner beta.

- Sweet framework almost ready for public release
- Tons of cofee and legal substances disintegrated to molecular structures
- Lots of features added like colorize tool, layer positions, animation offsets,
new drop down menu and so on. This is not how you’re suppose to make
MVP, but it’s how you make something you love.

v0.41 13.05.13 | New course of action
- Sweet framework will be build
- Category selection
- Grayscale or Harmonic color selection
- Flash animated previews

v0.00 04.01.13 | Day one.
v-0.01 10.12.12 | Animation script would be a great tool to have.
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